package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*?):[\d\D]*?xxx`)
var str = `test1:
Some random
multiline text herexxx
test2:
another multiline
Textxxx
value124:
again random Text
In multiple
linesxxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}