import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*?):[\\d\\D]*?xxx";
final String string = "test1:\n"
+ "Some random\n"
+ "multiline text herexxx\n"
+ "test2:\n"
+ "another multiline\n"
+ "Textxxx\n"
+ "value124:\n"
+ "again random Text\n"
+ "In multiple \n"
+ "linesxxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}