$re = '/(\w*?):[\d\D]*?xxx/m';
$str = 'test1:
Some random
multiline text herexxx
test2:
another multiline
Textxxx
value124:
again random Text
In multiple
linesxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);