#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(S?g?[mfds]|S?G*g[msdf])$"
Local $sString = "Legal: Should Match : " & @CRLF & _
"m" & @CRLF & _
"gf" & @CRLF & _
"Ggm" & @CRLF & _
"GGgf" & @CRLF & _
"Ss" & @CRLF & _
"SGgs" & @CRLF & _
"" & @CRLF & _
"Should Not Match: " & @CRLF & _
"mf" & @CRLF & _
"Gm" & @CRLF & _
"SSm" & @CRLF & _
"GSm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")