using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(S?g?[mfds]|S?G*g[msdf])$";
string input = @"Legal: Should Match :
m
gf
Ggm
GGgf
Ss
SGgs
Should Not Match:
mf
Gm
SSm
GSm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}