re = /^(S?g?[mfds]|S?G*g[msdf])$/m
str = 'Legal: Should Match :
m
gf
Ggm
GGgf
Ss
SGgs
Should Not Match:
mf
Gm
SSm
GSm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end