$re = '/^(S?g?[mfds]|S?G*g[msdf])$/m';
$str = 'Legal: Should Match :
m
gf
Ggm
GGgf
Ss
SGgs
Should Not Match:
mf
Gm
SSm
GSm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);