import re
regex = re.compile(r"^(S?g?[mfds]|S?G*g[msdf])$", flags=re.MULTILINE)
test_str = ("Legal: Should Match : \n"
"m\n"
"gf\n"
"Ggm\n"
"GGgf\n"
"Ss\n"
"SGgs\n\n"
"Should Not Match: \n"
"mf\n"
"Gm\n"
"SSm\n"
"GSm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")