#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^google(?:\.(?:[a-z]{1,2}|[a-z]{4,}|[^c.\n][a-z]{2}|[a-z][^o.\n][a-z]|[a-z]{2}[^m.\n])|\.com\.(?:[a-z]|[a-z]{3,}|[^a.\n][a-z]|[a-z][^u.\n])|(?:\.[a-z]+){3})(?:\.[a-z]+)*$"
Local $sString = "google.co" & @CRLF & _
"google.org" & @CRLF & _
"google.uk" & @CRLF & _
"google.com.pk" & @CRLF & _
"google.co.uk" & @CRLF & _
"" & @CRLF & _
"google.com" & @CRLF & _
"google.com.au"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")