import Foundation
let pattern = #"^google(?:\.(?:[a-z]{1,2}|[a-z]{4,}|[^c.\n][a-z]{2}|[a-z][^o.\n][a-z]|[a-z]{2}[^m.\n])|\.com\.(?:[a-z]|[a-z]{3,}|[^a.\n][a-z]|[a-z][^u.\n])|(?:\.[a-z]+){3})(?:\.[a-z]+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
google.co
google.org
google.uk
google.com.pk
google.co.uk
google.com
google.com.au
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)