$re = '`^google(?:\.(?:[a-z]{1,2}|[a-z]{4,}|[^c.\n][a-z]{2}|[a-z][^o.\n][a-z]|[a-z]{2}[^m.\n])|\.com\.(?:[a-z]|[a-z]{3,}|[^a.\n][a-z]|[a-z][^u.\n])|(?:\.[a-z]+){3})(?:\.[a-z]+)*$`m';
$str = 'google.co
google.org
google.uk
google.com.pk
google.co.uk
google.com
google.com.au';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);