import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^google(?:\\.(?:[a-z]{1,2}|[a-z]{4,}|[^c.\\n][a-z]{2}|[a-z][^o.\\n][a-z]|[a-z]{2}[^m.\\n])|\\.com\\.(?:[a-z]|[a-z]{3,}|[^a.\\n][a-z]|[a-z][^u.\\n])|(?:\\.[a-z]+){3})(?:\\.[a-z]+)*$";
final String string = "google.co\n"
+ "google.org\n"
+ "google.uk\n"
+ "google.com.pk\n"
+ "google.co.uk\n\n"
+ "google.com\n"
+ "google.com.au";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}