using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Line \d+: ";
string input = @"Line 15: 68.68259216
Line 22: 46.4267076
Line 29: 158.30325204";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}