import re
regex = re.compile(r"Line \d+: ", flags=re.MULTILINE)
test_str = ("Line 15: 68.68259216\n"
"Line 22: 46.4267076\n"
"Line 29: 158.30325204")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")