$re = '/Line \d+: /m';
$str = 'Line 15: 68.68259216
Line 22: 46.4267076
Line 29: 158.30325204';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);