re = /Line \d+: /m
str = 'Line 15: 68.68259216
Line 22: 46.4267076
Line 29: 158.30325204'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end