const regex = /Line \d+: /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Line \\d+: ', 'gm')
const str = `Line 15: 68.68259216
Line 22: 46.4267076
Line 29: 158.30325204`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}