using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",\d{2}\,(.*),\""\d{4}-\d{2}-\d{2}\w\d{2}:\d{2}:\d{2}-\d{2}:\d{2}\"",\""\w{3}""";
string input = @"""123"",""456"",,17,""hello,"" how are you this, fine, highly caffienated morning,"",""2018-05-29T18:58:10-05:00"",""XYZ"",
""345"",""737"",,16,""Heading to a ""meeting"", unprepared while trying to be ""awake"",""2018-05-29T18:58:10-05:00"",""ACD"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}