import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",\\d{2}\\,(.*),\\\"\\d{4}-\\d{2}-\\d{2}\\w\\d{2}:\\d{2}:\\d{2}-\\d{2}:\\d{2}\\\",\\\"\\w{3}\"";
final String string = "\"123\",\"456\",,17,\"hello,\" how are you this, fine, highly caffienated morning,\",\"2018-05-29T18:58:10-05:00\",\"XYZ\", \n"
+ "\"345\",\"737\",,16,\"Heading to a \"meeting\", unprepared while trying to be \"awake\",\"2018-05-29T18:58:10-05:00\",\"ACD\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}