package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),\d{2}\,(.*),\"\d{4}-\d{2}-\d{2}\w\d{2}:\d{2}:\d{2}-\d{2}:\d{2}\",\"\w{3}"`)
var str = `"123","456",,17,"hello," how are you this, fine, highly caffienated morning,","2018-05-29T18:58:10-05:00","XYZ",
"345","737",,16,"Heading to a "meeting", unprepared while trying to be "awake","2018-05-29T18:58:10-05:00","ACD",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}