# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",\d{2}\,(.*),\"\d{4}-\d{2}-\d{2}\w\d{2}:\d{2}:\d{2}-\d{2}:\d{2}\",\"\w{3}\""
test_str = ("\"123\",\"456\",,17,\"hello,\" how are you this, fine, highly caffienated morning,\",\"2018-05-29T18:58:10-05:00\",\"XYZ\", \n"
"\"345\",\"737\",,16,\"Heading to a \"meeting\", unprepared while trying to be \"awake\",\"2018-05-29T18:58:10-05:00\",\"ACD\",")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.