// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m),\d{2}\,(.*),\"\d{4}-\d{2}-\d{2}\w\d{2}:\d{2}:\d{2}-\d{2}:\d{2}\",\"\w{3}""#).unwrap();
let string = "\"123\",\"456\",,17,\"hello,\" how are you this, fine, highly caffienated morning,\",\"2018-05-29T18:58:10-05:00\",\"XYZ\",
\"345\",\"737\",,16,\"Heading to a \"meeting\", unprepared while trying to be \"awake\",\"2018-05-29T18:58:10-05:00\",\"ACD\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}