using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<first>\d)(\k<first>)\d?(?<second>(?!\k<first>)\d)(\k<second>)";
string input = @"12345
11223
44433
15151
22551
22055
22022
11111
11122
11222
12526";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}