import Foundation
let pattern = #"(?<first>\d)(\k<first>)\d?(?<second>(?!\k<first>)\d)(\k<second>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12345
11223
44433
15151
22551
22055
22022
11111
11122
11222
12526
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)