$re = '/(?<first>\d)(\k<first>)\d?(?<second>(?!\k<first>)\d)(\k<second>)/';
$str = '12345
11223
44433
15151
22551
22055
22022
11111
11122
11222
12526';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);