const regex = /(?<first>\d)(\k<first>)\d?(?<second>(?!\k<first>)\d)(\k<second>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<first>\\d)(\\k<first>)\\d?(?<second>(?!\\k<first>)\\d)(\\k<second>)', 'g')
const str = `12345
11223
44433
15151
22551
22055
22022
11111
11122
11222
12526`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}