use strict;
my $str = '12345
11223
44433
15151
22551
22055
22022
11111
11122
11222
12526';
my $regex = qr/(?<first>\d)(\k<first>)\d?(?<second>(?!\k<first>)\d)(\k<second>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}