using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(### EXAMPLE ([0-9|[0-9]+))\n(```\n(```|```ps|```posh|```powershell)\n```\n)\n([\s\S]*?)\\`\\`\\`(\n\n|\n)([\s\S]*|\n)";
string input = @"### EXAMPLE 123
```
```powershell
```
$powershellVersion = '6 and lower'
$description = 'custom code fencing example WITH markdown description'
$names | Foreach-Object {} {
write-host 'indentation is respected'
Write-Host 'enormously long lines should not get cut off by our PlatyPS friends, ftw'
}
$emptyNewlinesInCode = $True
\`\`\`
The description would continue after first closing code fence.
This solution:
- respects indentation
- will treat description as markdown
- seems close to what comes natural
With this solution, the description itself could even contain code blocks:
\`\`\`js
$var = docusaurus.New($config);
\`\`\`
Pretty cool and the console becomes more readable too IMO, at least
you now see where the code ends and the explanation begins
\`\`\`
$unMonicked = ""should stay unmonicked, in other words powershell should not be added""
$indentationRespected = $True
$theBadNews - ""that PlatyPS seems to cut off this line if a .
is detected, wtf""
\`\`\`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}