$re = '/(### EXAMPLE ([0-9|[0-9]+))\n(```\n(```|```ps|```posh|```powershell)\n```\n)\n([\s\S]*?)\\\\`\\\\`\\\\`(\n\n|\n)([\s\S]*|\n)/m';
$str = '### EXAMPLE 123
```
```powershell
```
$powershellVersion = \'6 and lower\'
$description = \'custom code fencing example WITH markdown description\'
$names | Foreach-Object {} {
write-host \'indentation is respected\'
Write-Host \'enormously long lines should not get cut off by our PlatyPS friends, ftw\'
}
$emptyNewlinesInCode = $True
\\`\\`\\`
The description would continue after first closing code fence.
This solution:
- respects indentation
- will treat description as markdown
- seems close to what comes natural
With this solution, the description itself could even contain code blocks:
\\`\\`\\`js
$var = docusaurus.New($config);
\\`\\`\\`
Pretty cool and the console becomes more readable too IMO, at least
you now see where the code ends and the explanation begins
\\`\\`\\`
$unMonicked = "should stay unmonicked, in other words powershell should not be added"
$indentationRespected = $True
$theBadNews - "that PlatyPS seems to cut off this line if a .
is detected, wtf"
\\`\\`\\`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);