import Foundation
let pattern = ####"(### EXAMPLE ([0-9|[0-9]+))\n(```\n(```|```ps|```posh|```powershell)\n```\n)\n([\s\S]*?)\\`\\`\\`(\n\n|\n)([\s\S]*|\n)"####
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
### EXAMPLE 123
```
```powershell
```
$powershellVersion = '6 and lower'
$description = 'custom code fencing example WITH markdown description'
$names | Foreach-Object {} {
write-host 'indentation is respected'
Write-Host 'enormously long lines should not get cut off by our PlatyPS friends, ftw'
}
$emptyNewlinesInCode = $True
\`\`\`
The description would continue after first closing code fence.
This solution:
- respects indentation
- will treat description as markdown
- seems close to what comes natural
With this solution, the description itself could even contain code blocks:
\`\`\`js
$var = docusaurus.New($config);
\`\`\`
Pretty cool and the console becomes more readable too IMO, at least
you now see where the code ends and the explanation begins
\`\`\`
$unMonicked = "should stay unmonicked, in other words powershell should not be added"
$indentationRespected = $True
$theBadNews - "that PlatyPS seems to cut off this line if a .
is detected, wtf"
\`\`\`
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)