const regex = /(### EXAMPLE ([0-9|[0-9]+))\n(```\n(```|```ps|```posh|```powershell)\n```\n)\n([\s\S]*?)\\`\\`\\`(\n\n|\n)([\s\S]*|\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(### EXAMPLE ([0-9|[0-9]+))\\n(```\\n(```|```ps|```posh|```powershell)\\n```\\n)\\n([\\s\\S]*?)\\\\`\\\\`\\\\`(\\n\\n|\\n)([\\s\\S]*|\\n)', 'gm')
const str = `### EXAMPLE 123
\`\`\`
\`\`\`powershell
\`\`\`
\$powershellVersion = '6 and lower'
\$description = 'custom code fencing example WITH markdown description'
\$names | Foreach-Object {} {
write-host 'indentation is respected'
Write-Host 'enormously long lines should not get cut off by our PlatyPS friends, ftw'
}
\$emptyNewlinesInCode = \$True
\\\`\\\`\\\`
The description would continue after first closing code fence.
This solution:
- respects indentation
- will treat description as markdown
- seems close to what comes natural
With this solution, the description itself could even contain code blocks:
\\\`\\\`\\\`js
\$var = docusaurus.New(\$config);
\\\`\\\`\\\`
Pretty cool and the console becomes more readable too IMO, at least
you now see where the code ends and the explanation begins
\\\`\\\`\\\`
\$unMonicked = "should stay unmonicked, in other words powershell should not be added"
\$indentationRespected = \$True
\$theBadNews - "that PlatyPS seems to cut off this line if a .
is detected, wtf"
\\\`\\\`\\\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}