using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(Person in \(\s*\d+\s*(?:,\s*\d+\s*)*\)\)";
string input = @"location = ""Somewhere"" and (Person IN (4,1)) and status in (""Closed"")
location = ""Somewhere"" and (Person IN ( 4, 1,8,2, 10,24 ,32,15, 7 )) and status in (""Closed"")
location = ""Somewhere"" and (Person IN ()) and status in (""Closed"")
location = ""Somewhere"" and (Person IN ( 4 )) and status in (""Closed"")
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}