import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(Person in \\(\\s*\\d+\\s*(?:,\\s*\\d+\\s*)*\\)\\)";
final String string = "location = \"Somewhere\" and (Person IN (4,1)) and status in (\"Closed\")\n\n"
+ "location = \"Somewhere\" and (Person IN ( 4, 1,8,2, 10,24 ,32,15, 7 )) and status in (\"Closed\")\n\n"
+ "location = \"Somewhere\" and (Person IN ()) and status in (\"Closed\")\n\n"
+ "location = \"Somewhere\" and (Person IN ( 4 )) and status in (\"Closed\")\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}