package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\(Person in \(\s*\d+\s*(?:,\s*\d+\s*)*\)\)`)
var str = `location = "Somewhere" and (Person IN (4,1)) and status in ("Closed")
location = "Somewhere" and (Person IN ( 4, 1,8,2, 10,24 ,32,15, 7 )) and status in ("Closed")
location = "Somewhere" and (Person IN ()) and status in ("Closed")
location = "Somewhere" and (Person IN ( 4 )) and status in ("Closed")
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}