import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(src|href)=\"([0-9a-zA-Z_\\-\\/]+\\.(css|js|png|jpg|jpeg)(\\?v=\\d+)?)\"";
final String string = "<link rel=\"stylesheet\" media=\"print\" href=\"common/css/print.css?v=20111230\">\n"
+ "<link rel=\"stylesheet\" href=\"doc/docs.css\">\n"
+ "<img src=\"common/logos/logo-mysql-110x57.png\" alt=\"MySQL\" width=\"110\" height=\"57\">\n"
+ "<script src=\"common/js/metrics/s_code_remote.js\"></script>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}