use strict;
my $str = '<link rel="stylesheet" media="print" href="common/css/print.css?v=20111230">
<link rel="stylesheet" href="doc/docs.css">
<img src="common/logos/logo-mysql-110x57.png" alt="MySQL" width="110" height="57">
<script src="common/js/metrics/s_code_remote.js"></script>';
my $regex = qr/(src|href)="([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}