import Foundation
let pattern = #"(src|href)="([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<link rel="stylesheet" media="print" href="common/css/print.css?v=20111230">
<link rel="stylesheet" href="doc/docs.css">
<img src="common/logos/logo-mysql-110x57.png" alt="MySQL" width="110" height="57">
<script src="common/js/metrics/s_code_remote.js"></script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)