import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(TYPEA-|BTYPE-)[A-Z]{4,10}$";
final String string = "TYPEA-ABCDEFG\n"
+ "BTYPE-GFEDCBA\n"
+ "BTYPE-GFE\n"
+ "BTYPE-GFEGFEGFEGF\n"
+ "ATYPE-GFEDCBA\n"
+ "BTYPE-GFEDCBAa\n"
+ "BTYPE-GFED1CBA\n"
+ "TYPEA-BTYPE-GFEDCBA\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}