// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(TYPEA-|BTYPE-)[A-Z]{4,10}$").unwrap();
let string = "TYPEA-ABCDEFG
BTYPE-GFEDCBA
BTYPE-GFE
BTYPE-GFEGFEGFEGF
ATYPE-GFEDCBA
BTYPE-GFEDCBAa
BTYPE-GFED1CBA
TYPEA-BTYPE-GFEDCBA
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}