$re = '/^(TYPEA-|BTYPE-)[A-Z]{4,10}$/m';
$str = 'TYPEA-ABCDEFG
BTYPE-GFEDCBA
BTYPE-GFE
BTYPE-GFEGFEGFEGF
ATYPE-GFEDCBA
BTYPE-GFEDCBAa
BTYPE-GFED1CBA
TYPEA-BTYPE-GFEDCBA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);