re = /^(TYPEA-|BTYPE-)[A-Z]{4,10}$/m
str = 'TYPEA-ABCDEFG
BTYPE-GFEDCBA
BTYPE-GFE
BTYPE-GFEGFEGFEGF
ATYPE-GFEDCBA
BTYPE-GFEDCBAa
BTYPE-GFED1CBA
TYPEA-BTYPE-GFEDCBA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end