const regex = /^(TYPEA-|BTYPE-)[A-Z]{4,10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(TYPEA-|BTYPE-)[A-Z]{4,10}$', 'gm')
const str = `TYPEA-ABCDEFG
BTYPE-GFEDCBA
BTYPE-GFE
BTYPE-GFEGFEGFEGF
ATYPE-GFEDCBA
BTYPE-GFEDCBAa
BTYPE-GFED1CBA
TYPEA-BTYPE-GFEDCBA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}