using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:key|api|token|secret|client|passwd|password|access|auth)(?:[0-9a-z\-_\t .]{0,20})(?:[\s|']|[\s|""]){0,3}(?:=|>|:=|\|\|:|<=|=>|:)(?:'|\""|\s|=|\x60){0,5}([0-9a-z\-_.=]{10,150})(?:['|\""|\n|\r|\s|\x60]|$)";
string input = @"String endpoint = ""xxx"",
String accessld = ""OiWVONCs805VUAAu"";
String accessKey = ""EwlgpCnXDwT93YMVDb2G60mv9ne81"".
String projectName = ""xxx"",
String topicName = ""xxx""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}