const regex = new RegExp('(?i)(?:key|api|token|secret|client|passwd|password|access|auth)(?:[0-9a-z\\-_\\t .]{0,20})(?:[\\s|\\']|[\\s|"]){0,3}(?:=|>|:=|\\|\\|:|<=|=>|:)(?:\\'|\\"|\\s|=|\\x60){0,5}([0-9a-z\\-_.=]{10,150})(?:[\\'|\\"|\\n|\\r|\\s|\\x60]|$)', 'gm')
const str = `String endpoint = "xxx",
String accessld = "OiWVONCs805VUAAu";
String accessKey = "EwlgpCnXDwT93YMVDb2G60mv9ne81".
String projectName = "xxx",
String topicName = "xxx"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}