// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)(?:key|api|token|secret|client|passwd|password|access|auth)(?:[0-9a-z\-_\t .]{0,20})(?:[\s|']|[\s|"]){0,3}(?:=|>|:=|\|\|:|<=|=>|:)(?:'|\"|\s|=|\x60){0,5}([0-9a-z\-_.=]{10,150})(?:['|\"|\n|\r|\s|\x60]|$)"#).unwrap();
let string = "String endpoint = \"xxx\",
String accessld = \"OiWVONCs805VUAAu\";
String accessKey = \"EwlgpCnXDwT93YMVDb2G60mv9ne81\".
String projectName = \"xxx\",
String topicName = \"xxx\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}