package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:key|api|token|secret|client|passwd|password|access|auth)(?:[0-9a-z\-_\t .]{0,20})(?:[\s|']|[\s|"]){0,3}(?:=|>|:=|\|\|:|<=|=>|:)(?:'|\"|\s|=|\x60){0,5}([0-9a-z\-_.=]{10,150})(?:['|\"|\n|\r|\s|\x60]|$)`)
var str = `String endpoint = "xxx",
String accessld = "OiWVONCs805VUAAu";
String accessKey = "EwlgpCnXDwT93YMVDb2G60mv9ne81".
String projectName = "xxx",
String topicName = "xxx"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}