#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^E\h+|\G(?!^),?(\d{1,4}-\d{1,4}))"
Local $sString = "E 1-6,44-80" & @CRLF & _
"E 10-76" & @CRLF & _
"E 44-80,233-425" & @CRLF & _
"E 19-55,62-83,86-119,200-390" & @CRLF & _
"" & @CRLF & _
"200-390"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")