re = /(?:^E\h+|\G(?!^),?(\d{1,4}-\d{1,4}))/m
str = 'E 1-6,44-80
E 10-76
E 44-80,233-425
E 19-55,62-83,86-119,200-390
200-390'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end