use strict;
my $str = 'E 1-6,44-80
E 10-76
E 44-80,233-425
E 19-55,62-83,86-119,200-390
200-390';
my $regex = qr/(?:^E\h+|\G(?!^),?(\d{1,4}-\d{1,4}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}