using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^E\h+|\G(?!^),?(\d{1,4}-\d{1,4}))";
string input = @"E 1-6,44-80
E 10-76
E 44-80,233-425
E 19-55,62-83,86-119,200-390
200-390";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}